Talk:Download

From Industrial-Craft-Wiki
Revision as of 15:22, 15 April 2012 by Feanturi (talk | contribs)
Jump to: navigation, search

Latest Version

Please make a 'latest version' section at the top of the article, to include the latest version of IC and the compatible version of minecraft. Most users are not familiar with version compatibility and expect software to 'just work'. Version (in)compatibility is what stops a lot of people from discovering and utilizing MC mods, and I think we should clearly point it out to educate everyone. Medicdude 02:33, 15 April 2012 (CEST)

Quote.pngwell all needed information (f.e. latest IC version, compatible MC version) are given. so i see no point in changing something?Quote.png
by Feanturi(-)